Gen 3 Insight Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have found this issue to be true with several iPhone X and 2019 Honda owners. While we all have experienced the problem and have all tried many different workarounds, none of us have found a solution. Have any of you been able to find a solution?

Here’s what is happening and what we have tried.

Sometime after setting up an iPhone X, XS or XR to run CarPlay on a 2019 Honda insight or Honda Accord the head unit will freeze. Eventually it will tell us that the smart phone connect utility app has stopped working and that it must be force quit. Whether we accept to do that or not, the app stops working. Occasionally, turning off the car and turning it back on will fix the problem. Almost always, the only way to fix it is to do a factory data reset. This however only works temporarily and occurs repeat. Often times I can keep my phone plugged in and nothing will happen for days while other times it will freeze up after minutes of use.

We all have tried the obvious, Apple certified cord, up-to-date software on phone and car and so forth. We have even tried some other options by turning Bluetooth off, turning off android auto, turning off Wi-Fi, and entering debug mode on the head unit to play with a few options. Ultimately, nothing works. I’ve spoken with the car dealer many times and while they are aware of the issue, no one has a fix. We all know that the issue is with Honda, but they have yet to push out a fix. I’m hoping that someone has just been able to find a way to actually make it work without waiting for a software update from Honda.
 

·
Registered
Joined
·
836 Posts
Just curious, do you control the phone with the car, or by using the screen on the phone? The reason I ask, is that I've noticed some issues when my girlfriend uses the phone while it's plugged into the car, with CarPlay. But we haven't experienced issues when the car is used to control the phone's functions. I've had Spotify fail to load a playlist from time to time, but other than that, no issues with our iPhone Xs's.

When using the phone, I've seen the screen freeze once. Most common issue is that if the screen is used, the volume will lock to a maximum of 11. And unplugging and reconnecting gets rid of that issue.
 

·
Super Moderator
Joined
·
2,347 Posts
I have found this issue to be true with several iPhone X and 2019 Honda owners. While we all have experienced the problem and have all tried many different workarounds, none of us have found a solution. Have any of you been able to find a solution?

Here’s what is happening and what we have tried.

Sometime after setting up an iPhone X, XS or XR to run CarPlay on a 2019 Honda insight or Honda Accord the head unit will freeze. Eventually it will tell us that the smart phone connect utility app has stopped working and that it must be force quit. Whether we accept to do that or not, the app stops working. Occasionally, turning off the car and turning it back on will fix the problem. Almost always, the only way to fix it is to do a factory data reset. This however only works temporarily and occurs repeat. Often times I can keep my phone plugged in and nothing will happen for days while other times it will freeze up after minutes of use.

We all have tried the obvious, Apple certified cord, up-to-date software on phone and car and so forth. We have even tried some other options by turning Bluetooth off, turning off android auto, turning off Wi-Fi, and entering debug mode on the head unit to play with a few options. Ultimately, nothing works. I’ve spoken with the car dealer many times and while they are aware of the issue, no one has a fix. We all know that the issue is with Honda, but they have yet to push out a fix. I’m hoping that someone has just been able to find a way to actually make it work without waiting for a software update from Honda.
I wonder if its an app running in the background causing your system to freeze up. I had a VPN app that kept disconnecting me from CarPlay whenever I had it on running in the background on my iPhone. Turning off the VPN app fixed my disconnect issues. Otherwise it was disconnecting my CarPlay about every 5-10 minutes.


You can also contact NCDS at 877-545-0055 ext. 120 and file a dispute against Honda to force a fix (Found this information in the warranty manual).
 

·
Super Moderator
Joined
·
3,327 Posts
I wonder if its an app running in the background causing your system to freeze up. I had a VPN app that kept disconnecting me from CarPlay whenever I had it on running in the background on my iPhone. Turning off the VPN app fixed my disconnect issues. Otherwise it was disconnecting my CarPlay about every 5-10 minutes.

You can also contact NCDS at 877-545-0055 ext. 120 and file a dispute against Honda to force a fix (Found this information in the warranty manual).
NCDS description sounds like it's there to be a mediator/arbitrator, one-step short of taking Honda to court... but maybe this is how class action lawsuits get started and issues fixed.
 

Attachments

·
Registered
Joined
·
836 Posts
VPN's would generally be considered a user issue, not a manufacturer issue. The problem with VPN's is they love to mask your location, which doesn't seem like a big deal until your car, which has a gps/satellite location disagrees with your phones location.

Could Honda disable this from the infotainment, sure, but just as your vpn is working to protect your data, the infotainment system also has built in securities to block outside intrusion.

Does the OP also use a vpn service?
 

·
Super Moderator
Joined
·
2,347 Posts
VPN's would generally be considered a user issue, not a manufacturer issue. The problem with VPN's is they love to mask your location, which doesn't seem like a big deal until your car, which has a gps/satellite location disagrees with your phones location.

Could Honda disable this from the infotainment, sure, but just as your vpn is working to protect your data, the infotainment system also has built in securities to block outside intrusion.

Does the OP also use a vpn service?
@SisuWest had reported his disconnect issue here for awhile(since January?). From what I remember, he has tried resetting his phone, updating to the latest iOS, using a different phone, but it never fixed his issue with the display audio screen crashing.


I brought up the possibility an app running in the background might be causing his CarPlay system to crash because I had it happened with a VPN app. I think it might be his display audio unit being defective so I suggested calling NCDS cause his Honda dealership isn't offering him a solution but to wait...
 

·
Registered
Joined
·
312 Posts
Weirdly, the head unit doesn't undergo a true restart every time you turn the car off and on. It seems like it's just asleep. You can force it to restart using these instructions that I found in another thread that @insightfully probably has on speed dial.

To restart the Display Audio, put your foot on brake, start, pause 1 second, put in reverse, pause 1 second, put in neutral.

I had OP's problem once, and did the factory reset, but haven't had the problem since. I credit that to the unstable head unit that is always rebooting.
 

·
Registered
Joined
·
44 Posts
This isn't just a Honda issue. Carplay used to quit on all of my VW's and my wife's Kia. I have found that unless your usb cable is in perfect condition, with absolutely no kinks in it whatsoever, it seems to work better. I sure wish Carplay would work via bluetooth. Seems like it has caused more of a dangerous situation by having to unplug/re-plug the cable in numerous times while driving.
 

·
Super Moderator
Joined
·
3,327 Posts
Weirdly, the head unit doesn't undergo a true restart every time you turn the car off and on. It seems like it's just asleep. You can force it to restart using these instructions that I found in another thread that @insightfully probably has on speed dial.

To restart the Display Audio, put your foot on brake, start, pause 1 second, put in reverse, pause 1 second, put in neutral.

I had OP's problem once, and did the factory reset, but haven't had the problem since. I credit that to the unstable head unit that is always rebooting.

@andrew28 had it on lock this time around. This recent post has links to the tips for screen reboot:
https://www.gen3insight.com/forum/15720-post3.html
 

·
Registered
Joined
·
23 Posts
Discussion Starter #10
Just curious, do you control the phone with the car, or by using the screen on the phone? The reason I ask, is that I've noticed some issues when my girlfriend uses the phone while it's plugged into the car, with CarPlay. But we haven't experienced issues when the car is used to control the phone's functions. I've had Spotify fail to load a playlist from time to time, but other than that, no issues with our iPhone Xs's.

When using the phone, I've seen the screen freeze once. Most common issue is that if the screen is used, the volume will lock to a maximum of 11. And unplugging and reconnecting gets rid of that issue.
I have used CarPlay both via my phone and on-screen. Same results. In talking to a Honda service agent, he has found the same problem with his iPhone X and 2019 Honda accord. He thinks it is as a result of the app switcher within the iPhone X. I have tried force quitting every single app when I start up the vehicle but unfortunately that hasn’t resolved it. I’m hoping that iOS 13 will fix a lot of these issues as it is a major update for CarPlay.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #11
[/quote]
I wonder if its an app running in the background causing your system to freeze up. I had a VPN app that kept disconnecting me from CarPlay whenever I had it on running in the background on my iPhone. Turning off the VPN app fixed my disconnect issues. Otherwise it was disconnecting my CarPlay about every 5-10 minutes.


You can also contact NCDS at 877-545-0055 ext. 120 and file a dispute against Honda to force a fix (Found this information in the warranty manual).[/QUOTE]

I have thought the same thing. I have gone through the process of force quitting every single app when I plug in the phone and only use the apps that are available on CarPlay. I still get the same results. It is crashed on me twice today already. I do have a VPN installed but it isn’t running. Perhaps I’ll try removing that app altogether.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #12
Weirdly, the head unit doesn't undergo a true restart every time you turn the car off and on. It seems like it's just asleep. You can force it to restart using these instructions that I found in another thread that @insightfully probably has on speed dial.

To restart the Display Audio, put your foot on brake, start, pause 1 second, put in reverse, pause 1 second, put in neutral.

I had OP's problem once, and did the factory reset, but haven't had the problem since. I credit that to the unstable head unit that is always rebooting.
I have tried that reboot process before and couldn’t get it to work. However, I just got it to work this time. I will report back if there are any changes, but I’m not very optimistic anymore.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #13
Weirdly, the head unit doesn't undergo a true restart every time you turn the car off and on. It seems like it's just asleep. You can force it to restart using these instructions that I found in another thread that @insightfully probably has on speed dial.

To restart the Display Audio, put your foot on brake, start, pause 1 second, put in reverse, pause 1 second, put in neutral.

I had OP's problem once, and did the factory reset, but haven't had the problem since. I credit that to the unstable head unit that is always rebooting.
I have tried that reboot process before and couldn’t get it to work. However, I just got it to work this time. I will report back if there are any changes, but I’m not very optimistic anymore.
I got the reboot thing to work and CarPlay froze 2 min later. I guess I can check another thing off the list that won’t work.
 

·
Super Moderator
Joined
·
2,347 Posts
I got the reboot thing to work and CarPlay froze 2 min later. I guess I can check another thing off the list that won’t work.
You should really consider filing a dispute with NCDS if your Honda dealership is just brushing you off and ask Honda for a replacement display audio screen with updated software. It seems like your display audio is defective. Another forum poster had his replaced. https://www.gen3insight.com/forum/282-2019-honda-insight-complaints-issues-problems/2205-frozen-lcd-infotainment-screen-start-up-2.html#post12980
 

·
Registered
Joined
·
34 Posts
I found my screen went blank every time the HondaLink app started on my phone. I deleted the app from my iPhone earlier this week and have not had the issue reoccur yet.
Would be interested to see if anyone can replicate solution, or i’ll post again if the screen shuts off while I test this out.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #16
I’m happy to say that since I’ve upgraded to iOS 13, I haven’t had this issue...so far. I still have some off issues but it’s much better than what was happening before.
 
1 - 16 of 16 Posts
Top