Gen 3 Insight Forum banner
1 - 5 of 5 Posts

Registered
Joined
10 Posts
Discussion Starter · #1 ·
I have 2 codes,

Where is this valve?

P24C1 Vacuum switching valve stuck open and P1462 (which i cant find what is for, it supposed to be emission related as well... but google shows as Air conditioner pressure.)

When the check engine is On the engine vibrates, but when I reset the light everything is good for like 5 days.
then it comes back and starts shaking...

sounds like a valve is really getting stuck..
But which valve is it.. where it is..


BTW I put a new canister on this car. but this canister doesnt have a electric valve is just the box. I didnt get fix 馃ス
 

Registered
Joined
316 Posts
The troubleshooting guide for the codes is not much help without a HDS. The generic evap one might be of use.

As for the vacuum valve, I am guessing it would be what is on page 19 of the last attachment.
 

Attachments

Registered
Joined
10 Posts
Discussion Starter · #4 ·
Then there is parts info...
Thank you very much for your replies this is really helpful!!!! I love this forum. I gonna try to change the purge valve at the front of the car.
So far I changed the canister and the fuel tank valve but I am still getting the codes..
If changing the purge valve does not work I will replace the EVAP check module next to the canister and let you guys know if it works.
 

Registered
Joined
10 Posts
Discussion Starter · #5 ·
SOLVED
So i replaced the Evap leak check module, but the check engine light came back... This is the funny part.
The Canister Purge solenoid valve is at front on top of the engine, I didn't want to change it because my car is a Salvage Flooded car.
So I assume the problem will be under the car not on top of the engine but I replace every single thing in the EVAP system that is located on the bottom. And didnt work. (Replaced the fuel tank valve, the canister, the leakcheck module) and THE SOLUTION WAS replacing the purge valve.
The check engine have not come back in 3 weeks but the engine is still checks a lot sometimes, he might be another problem but as long as the car doesn't have this annoying light I'm happy.

I was too stubborn, i should have replaced this valve from the beggining. It cost me $130.

Oh well.. THANK YOU ALL!!


here is the previous thread.

 
1 - 5 of 5 Posts
Top